黑基网 首页 资讯 IT业界 查看内容

多版本官方OS X安装程序受证书过期影响无法运行

2016-3-4 14:09| 投稿: lofor

摘要: 验证三方服务和应用的苹果全球开发者证书(Apple's Worldwide Developer Certificate)已于今年二月14日过期,开发者需要苹果颁布的更新证书来为开发应用进行升级。据外媒报道,2016年2月14日前从Mac App Store下载 ...

验证三方服务和应用的苹果全球开发者证书(Apple's Worldwide Developer Certificate)已于今年二月14日过期,开发者需要苹果颁布的更新证书来为开发应用进行升级。据外媒报道,2016年2月14日前从Mac App Store下载的多个版本OS X系统安装程序(OS X Installer)已经无法正常工作,原因就是证书过期导致其无法通过验证。

受影响的有OS X El Capitan版本安装程序、OS X Mavericks和OS X Mountain Lion这些版本的安装器也无法正常工作。由于许多用户早前将OS X安装程序用来创建成USB启动盘,用户最近才发现这些安装程序由于证书过期已经无法通过验证。OS X El Capitan系统的安装程序可以通过从Mac App Store重新下载新版本解决,不过对于OS X Mavericks和OS X Mountain Lion等老版本的系统,已经很难从Mac App Store中获取新版本的安装程序了。Randy Singer提供了一个变通的解决方法,通过将系统设定成2月14日之前的日期,即可让安装程序先正常工作。例如:

1、当在你通过OS X Installer进行系统安装时,进入通用工具-选择“终端”

2、在终端输入“date 0201010116”

3、退出终端即可继续安装进程

该终端命令能够将系统时间设定为2016年2月1日,暂时绕过证书过期验证,之后需手动改时间。

小编推荐:欲学习电脑技术、系统维护、网络管理、编程开发和安全攻防等高端IT技术,请 点击这里 注册黑基账号,公开课频道价值万元IT培训教程免费学,让您少走弯路、事半功倍,好工作升职加薪!



免责声明:本文搜集整理自互联网,版权归原作者所有,文中所述不代表本站观点,若有侵权或转载等不当之处请联系我们处理,请我们一起为维护良好的互联网秩序而努力!联系方式见网站首页右下角。


鲜花
1

握手

雷人

路过

鸡蛋

刚表态过的朋友 (1 人)

  • 握手

    匿名

相关阅读

最新评论


新出炉

返回顶部