黑基Web安全攻防班
黑基网 首页 资讯 互联网 查看内容

开源模拟器 QEMU 3.0.0 发布 包含大量兼容性改进

2018-8-16 10:30| 投稿: lofor |来自: 互联网

摘要: QEMU 3.0.0 已发布,QEMU 是一个通用的开源模拟器和虚拟机。需注意的是,由于无法进行测试,QEMU在未来的版本中可能会放弃对以下主机的支持(3.0.0 版本会提示不支持,但仍可正常使用)。 GNU/kFreeBSDDragonFly BS ...

QEMU 3.0.0 已发布,QEMU 是一个通用的开源模拟器和虚拟机。需注意的是,由于无法进行测试,QEMU 在未来的版本中可能会放弃对以下主机的支持(3.0.0 版本会提示不支持,但仍可正常使用)。

  • GNU/kFreeBSD

  • DragonFly BSD

  • Solaris

  • Haiku

不兼容更改

  • Option "-no-kvm-pit-reinjection" has been removed. Use "-global kvm-pit.lost_tick_policy=discard" instead.

  • Option "-no-kvm-irqchip" has been removed. Use "-machine kernel_irqchip=off" instead.

  • The "vlan" parameter of the "-net" option has been removed. Use "-netdev" with IDs or the "hubport" netdev instead.

  • The deprecated -drive options "geometry", "addr" and "serial" have been removed. Use "-drive if=none" and pass the options to "-device" instead.

  • The "xlnx-ep108" machine has been replaced by the "xlnx-zcu102" machine.

  • The qemu-img "convert -s snapshot_id_or_name" argument has been removed. Use "convert -l snapshot_param" instead.

  • PPC support for explicitly allocated RMAs has been removed (kernel support removed in 2015).

  • The default for VFIO's "display" option has been changed from "auto" to "off", because "auto" requires an OpenGL-compatible configuration for vGPUs that require GL support.

  • The deprecated xlnx-ep108 machine was removed.

  • Some 32-bit guests on the "virt" machine may need "-machine highmem=off" if they are unable to support LPAE and are confused by the PCI ECAM now being above the 4GB mark in the address space

已弃用选项和功能

  • The "arch" output member of the "query-cpus-fast" command is deprecated. Use the "target" output member instead.

  • Option "-virtioconsole" is deprecated, use "-device virtconsole" instead.

  • The non-functional "-clock" option will be removed soon.

  • The "pc-0.10" and "pc-0.11" machines are now deprecated. Use newer machine types instead.

  • Option "-enable-hax" is deprecated. Use "-accel hax" instead.

  • The "arch" memeber in the reply to query-cpus-fast is deprecated, use "target" instead.

  • The "file" driver for drives is no longer appropriate for character or host devices and will only accept regular files (S_IFREG). Use host_cdrom or host_device instead.

后续不兼容的更改

  • Three options are using different names on the command line and in configuration file. In particular:

    • The "acpi" configuration file section matches command-line option "acpitable";

    • The "boot-opts" configuration file section matches command-line option "boot";

    • The "smp-opts" configuration file section matches command-line option "smp".

-readconfig will standardize on the name for the command line option.

  • Behavior of automatic calculation of SMP topology when some SMP topology options for -smp are omitted (sockets, cores, threads) will change in the future. If guest ABI needs to be preserved on upgrades while using the SMP topology options, users should either set set all options explicitly (sockets, cores, threads), or omit all of them.

  • Devices "allwinner-a10", "pc87312", "ssi-sd" will be configured with explicit properties instead of implicitly. This is unlikely to affect users.

  • For x86, specifying a CPUID feature with both "+feature/-feature" and "feature=on/off" will cause a warning. The current behavior for this combination ("+feature/-feature" wins over "feature=on/off") will be changed so that "+feature" and "-feature" will be synonyms for "feature=on" and "feature=off" respectively).

  • The read-only block drivers "bochs", "cloop" and "dmg" as well as "rbd" and "vvfat" in certain read-only configurations will no longer enable read-only mode automatically. It will be necessary to specify "read-only=on" explicitly on the command line and in QMP commands for the setup to keep working; the default "read-only=off" setting will result in an error.

  • On s390x, using KVM with a Linux host kernel version < 3.15 has been broken since QEMU version 2.10. This will not be fixed unless a need is communicated (otherwise the code will be removed in the near future, so that you need at least Linux kernel version 3.15 on the host to run KVM on System z)

更多细节请查阅 wiki :

下载地址:


小编推荐:欲学习电脑技术、系统维护、网络管理、编程开发和安全攻防等高端IT技术,请 点击这里 注册黑基账号,公开课频道价值万元IT培训教程免费学,让您少走弯路、事半功倍,好工作升职加薪!

本文出自:https://hot.cnbeta.com/articles/game/757733

免责声明:本文由投稿者转载自互联网,版权归原作者所有,文中所述不代表本站观点,若有侵权或转载等不当之处请联系我们处理,让我们一起为维护良好的互联网秩序而努力!联系方式见网站首页右下角。


鲜花

握手

雷人
1

路过

鸡蛋

刚表态过的朋友 (1 人)

相关阅读

最新评论

最新

返回顶部